Computer Related > Apple TV via firestick Miscellaneous
Thread Author: Manatee Replies: 10

 Apple TV via firestick - Manatee
I was delighted to find there is an Apple TV app for for firestic but I am having problems.

It loads up, I signed in using my old Apple ID, and it even let me 'try it free' so I watched the first episode of Slow Horses.

Trouble is when I try to subscribe the connection simply fails and tells me to try later. This also fails. I tried using my phone to subscribe but get the same message.

I haven't tried using mobile data. My concern is that even if it works, the firestic app will still fail authentication when connected through my router.

It's a bit smart Hub 2. I would have tried changing DNS, but that is not allowed. I'm actually on Plusnet.

I think it might be something to do with my connection but I'm stuck. Googling suggests this has happened to others but has not yielded a working solution for me. TV is a 4 year old smart Panasonic (no Apple TV app available so far as I can see).

Any ideas? Has it happened to anyone else?
 Apple TV via firestick - Biggles
Perhaps someone now has the details for your Apple ID and has no further interest in providing any service to you.
 Apple TV via firestick - Manatee
I'm not sure there's much they can do with it at this point.
 Apple TV via firestick - Falkirk Bairn
Had problems with the Firestick - logged in but failed to play - 2 years old.

Switched the power off, re-booted and all was well.
 Apple TV via firestick - Manatee
I'll give it another go with full disconnect. I've tried restarting both phone and router. I suspect it's a port thing but the BT hub is not easy to fiddle with. If I can find the router Plusnet sent me 2 years ago I might try that although it's just the same router in white plastic instead of black.
 Apple TV via firestick - Falkirk Bairn
There are software updates for Firesticks at least once in the year.
Download the update and then a re-boot.

Cannot say it will cure your issues BUT worth a try.

 Apple TV via firestick - Manatee
Thanks FB. It appears to be up to date.

I've just realised I'm using 2 Ubiqiti access points rather than the router wifi. I wonder if that is messing it up.
Last edited by: Manatee on Tue 2 Jan 24 at 14:22
 Apple TV via firestick - Manatee
After a deal of faffing as I did not have the credentials for the APs, I have reset, reconfigured and updated them and I am still getting the same useless response with Apple TV. I go right through the payment carry on, approve it in my banking app, and then the authentication fails to complete.

I gave up with Apple products and services years ago because I found them anything but user-friendly. So nothing's changed.
 Apple TV via firestick - Robin O'Reliant
>> I gave up with Apple products and services years ago because I found them anything
>> but user-friendly. So nothing's changed.

You're not kidding. I've been trying to restart my Apple sub to watch Slow Horses and it came up "Password not recognised". So I went to the reset password link, typed in a new password and got the same response. Three attempts later I gave up.
 Apple TV via firestick - Zero
And people wonder why it gets pirated via kodi on a firestick........
 Apple TV via firestick - Manatee
Never discovered what was causing it, but in the end a friend gave me an Apple TV box. Being Apple, it took me half an hour to work out how to use the remote but I am now up and running.

Slow Horses is a truly excellent production, helped of course by Mick Herron's original stories. Far better than the glacially slow TV thrillers that have become the staple in recent years.
Latest Forum Posts